Purpose or Issue to Address: This process is to fix the various issues within Encompass printing.

Note: You must have Admin rights to your local machine. Please contact your IT Department for further information and support. These are provided only as a guideline and need to be evaluated based on your internal P&Ps. Lender Toolkit is not responsible for any actions taken here and are provided as solutions we've discovered to be successful. 


Step 1: Open Run Box (Press Windows Button + R)

Step 2: when Run box opens enter (regedit) press OK

Image Placeholder

Step 3:  Registry Key Location 64 Bit:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6 432Node\Ellie Mae\Encompass

Registry Key Location 32Bit:
HKEY_LOCAL_MACHINE\SOFTWARE\Ellie Mae\Encompass

Image Placeholder

Step 4: Click on Encompass Folder (Edit/New/String Value)

Image Placeholder

Image Placeholder

Step 5: Right Click to (Modify Value Data and Rename)

Image Placeholder

Step 6:  Edit String/Modify Value Data

Image Placeholder


Registry Key String Value Types and Resolution:

  •  UseWordSaveAsPdfAddIn = 1
    • Microsoft controls conversion for primarily word docs 
  • UseWordSaveAsPdfAddIn = 0
    • All encompass conversion through Amyuni 2.51
  • AdobeAPI = 1
    • Helps with Active X Child Window Issue
  •  UseWebKitConverter = 0
    • Solves conversion issue with the document viewing window being grey and showing error "The following error occurred when trying to prepare the document"
      UseEncompassDocumentConverter = 0
    • In 8.0, Ellie Mae switched from using Amyuni to using the Black Ice Printer to convert documents into PDF format when document conversion was off.  They found in some cases that this caused documents to appear with gibberish (especially when the original document was an HTML document).  In this situation, it is suggested that the client add the following registry key to their workstations. That registry key instructs Encompass to go back to using Amyuni for converting documents into PDF format.
  • WordBackgroundPrint = 0
    • MS Word tends to hang when printing eDisclosures
  • UseGDPictureConverter = 1
    • In 8.1, Ellie Mae added support for using a 3rd party component (GDPicture) to convert PDF documents into image format.  Ellie Mae suggested adding the following registry entry to any customers that have document conversion on and were experiencing problems after attaching PDF documents. This resolves several issues including the one where the user is not able to print from a Microsoft Office Product (e.g. Outlook, Word) after attaching a document to the eFolder.

Details / Symptom(s):

Users are receiving one of the following errors: 

  • "Printer not activated, error code -20" 
  • "Printer not activated, error code -30" 
  • "Printer not activated, error code -41"

Cause:


This error occurs when Microsoft Word is attempting to print using the installed Encompass printer. It is an indication that there may be a problem with the Microsoft Word installation or the Encompass printer.

Resolution:

We have found that when someone receives the below message it is a permission issue in the registry.

Solution:

To fix this issue you need to open regedit and go to the following registry key:

  1. HKey_Current_Config\Software\Encompass (Note: If the Encompass folder is not there, you will need to add it.)
  2. Then you right click on the Encompass folder and click on permissions
  3. Once there click on "Add" and type "Everyone" and click "Check Names"
  4. Next you need to click "Full Control" and click "Apply" or "Ok"
  5. Have the user restart their computer and that should fix the printer error.
Another Solution: 


  1. Repair the installation of Microsoft Office by going to "Programs and Features", selecting the Microsoft Office installation in the list of programs, and clicking "Change". This will launch the Microsoft Office setup which will provide a guide to repairing the installation. If problems continue, proceed to step 2.
  2. Reinstall the Encompass printer: 
  3. Download PDFConverter251 from
    http://download.elliemae.com/encompass/tools/amyuni/Converter2.51.zip (Hyperlink provided as a convenience only - please contact your Ellie Mae account rep for an update link, if needed)
  4. Open Devices and Printers in Windows.
  5. Locate and remove the Encompass printer.
  6. Run the previously downloaded file Converter251 to reinstall the printer.
  7. Open my computer and go to C:\Program Files\Encompass\Amyuni3.0.3.4
  8. Copy the (4) dll files and paste them to C:\Program Files\Encompass replacing the existing files.
  9. On the Windows taskbar, click Start, type cmd, and then click OK.
  10. In the Command Prompt window type "cd C:\Program Files\Encompass" and press enter
  11. type regsvr32 acpdfcrext.dll and press enter.
  12. Then type regsvr32 pdfcreactivex.dll and press enter.
  13. Close the command prompt and test issue again.
  14. If problems continue, proceed to step 15.
  15. Verify that the Encompass printer has a local port called PDF created. If not, then you will need to create one.
  16. Ensure that Adobe Reader is installed on the computer and is set to the default program for viewing .pdf files.
  17. Configure Adobe Reader to disable the Enhanced Security option by unchecking the "Enable Enhanced Security" check box found in the Security (Enhanced) section within Preferences in Adobe Reader.
  18. As a workaround, reference How to Set the UseWordSaveAsPdfAddIn Registry Value and set the value to 1.